Skip to end of metadata
Go to start of metadata


Copyright 2016 RDK Management, LLC. All rights reserved. The contents of this document are RDK Management, LLC Proprietary and Confidential and may not be distributed or otherwise disclosed without prior written permission of RDK Management, LLC.


No longer supported

Recommending to use dunfell build going forward.

Host Setup

NOTE: Observing fetch errors in VMs with Ubuntu14.x. Thus, suggesting to use VMs with Ubuntu16.x or higher.

Building

Note: Cloning the code before login once to code.rdkcentral.com, user would get the Authentication error, even though the account is in good standing and has all the required access. Please login to code.rdkcentral.com before attempting to clone.

To build, follow below instructions

Create workspace directory

mkdir <workspace dir>
cd <workspace dir>

OpenSync backhaul credential

Please get patch(service.patch) for meta-turris layer from Plume to apply backhaul credential(SSID:PSK). Please check Cloud Access Guide for more details.

Follow below instructions to create build with external sources

repo init -u https://code.rdkcentral.com/r/manifests -m rdkb-turris-pod-extsrc.xml -b rdk-next
repo sync -j4 --no-clone-bundle
cd meta-turris && git apply service.patch && cd ../
MACHINE=turris-extender source meta-turris/setup-environment build-turris-ext
bitbake rdk-generic-extender-image


Else, follow below instructions to create build with no external source

repo init -u https://code.rdkcentral.com/r/manifests -m rdkb-turris-pod-nosrc.xml -b rdk-next
repo sync -j4 --no-clone-bundle
cd meta-turris && git apply service.patch && cd ../
MACHINE=turris-extender source meta-turris/setup-environment build-turris-ext
bitbake rdk-generic-extender-image


Note. The kernel Image and root filesystem will be placed under <workspace dir>/build-turris-ext/tmp/deploy/images/turris-extender directory

Flashing procedure

  • No labels

4 Comments

    1. May be corporate network policy blocks the traffic. Build is going fine for us.

  1. Hi Yongjin Lim,

    Looks like, above mentioned fetch error occurs in VM with Ubuntu14.x but not in VMs with Ubuntu16.x or higher. Suspecting Openssl component installed in Ubuntu 14.x.

    1. Hi Manigandan Gopalakrishnan,

      I also realized it only happens in ubuntu 14.x. Is there any way to solve this problem in ubuntu 14.x?